Unable to integrate LDAP to Active Directory on SafeSquid


To integrate OpenLDAP with SafeSquid Active Directory we follow the documentation on this link:

https://docs.safesquid.com/wiki/Integra … _SafeSquid

However, even after following each of those steps, I am unable to connect to the SafeSquid directory. The directory is blank.

These are the settings I made:

There was a very small mistake. I have listed a few possibilities from which yours could be either one or more.

  1. Check your FQDN/IP address. You need to put either one of them and not both.
    If you are following the docs, it’s not necessary you need to put the same IP ( Your IP could be different.

  2. Check the Username carefully. Mine was supposed to be " cn=admin,dc=renayy,dc=local "

  3. Check the Basedn. In my case, it should have been " dc=renayy,dc=local "

  4. Check whether you have enabled protected authorization while integrating LDAP, i.e. add username and password when adding server details. Here’s a screenshot for reference.


After making changes, this is the whole configuration while adding a new LDAP server to SafeSquid.